Synth Forum

Notifications
Clear all

BUG: Strange SSS Event in v3.0

4 Posts
2 Users
0 Likes
2,020 Views
Jason
Posts: 7907
Illustrious Member
Topic starter
 

I was going one-by-one through the new content in OS V3.0 and noticed something strange and was able to reproduce it several times. I do not have a "sure fire" way of invoking the strangeness - but it wasn't difficult to try several times and 1-in-5 or so tries would go strange on me.

I was going between "First Strike" and "The Polysynth MW" - they're neighbors in the Category Search ordered by default while showing all presets. The first time I noticed this I was done "playing" with "First Strike" and switched to the next Perf ("The Polysynth MW" ) and boom - first time the strangeness happened. The drums from First Strike continued to play after the switch. When I lifted my hand from the keyboard - the "First Strike" drums were still playing. Not the entire ARP - but just a short part of it in a loop (1 measure? maybe 2 beats?).

What I'm accustomed to is that when switching performances - if I'm switching FROM a Performance with an ARP and/or motion sequence - the ARP and motion sequence of the "from" Performance will stop as soon as I switch Performances - even if held notes continue to sound from SSS. I am not accustomed to this kind of thing like an ARP to continue. Seems like some residue. Maybe something new in the pattern player that "shares" this memory not clearing when I switch and the residue playing. Who knows.

I went back to "First Strike" and tried reproducing. It didn't happen every time. Sometimes I'd switch the [SCENE] button (pick a different scene number) before the switch. I'm not sure which scene I was on the 1st time I did the switch. I varied how long I would hold down notes before switching. At any rate - every once and a while I could make "this" happen.

It's better heard than described. Maybe try to reproduce on other keyboards.

 
Posted : 02/11/2019 6:16 am
Manuel
Posts: 0
Eminent Member
 

It's the same on my Montage 8: I selected First Strike in the category search Main:Syn Lead / sub: All (it's the last performance) and when switching to the previous performance 8bit Dude or to Wax And Wane (the first performance of the Pad/Choir category) sometimes the bass synth arpeggio kept running and other times the sound SynLd Digital remained in the background like a drone.

 
Posted : 02/11/2019 8:14 am
Jason
Posts: 7907
Illustrious Member
Topic starter
 

How the sounds of the first Performance (even ARPs sometimes) persist when you lift all your fingers appears to be a bug to squash in a future firmware release. I'm fairly certain this is not the case of misunderstanding a feature.

I've asked for true SSS where ARPs and Motion Sequence can continue for the held notes through an SSS switch (that I would not have minded discovering) - but this isn't quite that. And I'm sure it was never intended to change how SSS works in pre-v3.0 firmware.

Since this doesn't occur 100% of the time - it smells of a corner case of some bases not covered in variable (register) initialization.

 
Posted : 02/11/2019 3:37 pm
Jason
Posts: 7907
Illustrious Member
Topic starter
 

Not that a sample size of 2 is proof positive - but typically bug reports get some response as either valid dismissal ("here's what you've missed in how it's supposed to work" ) or as capture ("we're looking into it" ).

Thanks for steering appropriately.

 
Posted : 08/11/2019 5:40 am
Share:

© 2024 Yamaha Corporation of America and Yamaha Corporation. All rights reserved.    Terms of Use | Privacy Policy | Contact Us