Synth Forum

Notifications
Clear all

Zone Setting

8 Posts
3 Users
0 Likes
592 Views
Dileepa
Posts: 0
Eminent Member
Topic starter
 

Hi there.
I am using Set List Maker on an iPad to change patches in my Montage7 and MODX7. It works so fine. But when I switch the Zone Settings on the keyboards they don't recognize program changes. What changes should I do? Please help me on this.
Thanks in advance.
Stay safe and healthy.

 
Posted : 08/02/2022 11:30 am
Dileepa
Posts: 0
Eminent Member
Topic starter
 

Thanks Bill.
I will refer to the link first.
Stay safe and healthy!!

 
Posted : 09/02/2022 2:50 am
Dileepa
Posts: 0
Eminent Member
Topic starter
 

Hi Bill. Hope you are fine and happy. I went through the link you have shared. But I didn't find the answer to my problem. I will describe step by step.

I send the program changes to Montage with "Set List Maker" app (iPad). An example of the tone is shown in Image 2. It works so fine at this stage. (Patches change).
If I need to send a program change to my Voicelive touch 2 I add a blank tone to MIDI 8. Image 3.
To do so or, to transpose the range of the harmonizer I switch on "Zone Settings" in Montage. Image 4.
At this point Montage won't recognize the property values. ie: Patches won't get changed.
Please let me know where have I gone wrong and how to get this working.
Thank you!!
Stay safe and healthy!!!

Attached files

 
Posted : 11/02/2022 2:30 pm
Jason
Posts: 7943
Illustrious Member
 

The Zone settings on image 4 do not send anything. No PC, no notes, no anything. The reason why is because the transmit channel is set to OFF. There are reasons to do this, but if you want to "reach" an external device (like Voicelive) then you need to change the transmit channel from "Off" to Channel 8 (channel 8 in this case since you've mentioned your external device is set to MIDI channel 8 - or any non-Off channel that matches your particular configuration in the general sense). There is not a requirement to have this Part on Part 8 since you can change the transmit channel to any value to match your Voicelive. Although it's not bad to keep this lined up - I just wanted to let you know you could have, hypothetically, had this as Part 7 also and set the transmit channel to MIDI Ch 8 under Zone settings.

Once you set the transmit channel, you'll see options for sending the MSB/LSB/PC (any one, selective ones, or all) to MIDI Ch 8 along with other on/off settings for various transmitted messages.

 
Posted : 11/02/2022 3:35 pm
Bad Mister
Posts: 12304
 

I'll add these points, if you want the MONTAGE to NOT sound from PART/ZONE #8 - set the "INT SW" = OFF (Internal Switch).

Jason is correct, you can use any SLOT to address your external device. Just recognize in your Performance as it stands you are set to transmit on MIDI Channels 1, 2, 3, 4, 5, 6 and 8. - all of these have an Internal Sound assigned and are linked by KBD CTRL (active)...

I see you have lowered the VOLUME Slider on Part 8 - probably to keep the INTERNAL MONTAGE Part from sounding. There is a better, a more flexible way.
You will want to INSTEAD, set the INT SW = OFF for Zone 8... this will prevent the MONTAGE from sounding the internal program assigned there... "this is the way!"

And it has the added benefit of giving you a Slider that can send CC7 to whatever is connected to that Part/Zone slot (#8)... It is going to act as the VOLUME Slider for your external device... the External Device is whatever you connect to the MIDI OUT, and set to the "Transmit Ch." you select for Zone 8
Remember you are already using Channels 1-6, for the MONTAGE, consider those Channels as already occupied...

Set your Zone 8 "Transmit Ch" = any channel 7 through 16 (make sure the external device is set to match your selection)

The Slider sends OUT via MIDI to your external ZONE on the Transmit Channel you set.
You will notice the red LED light - does not follow the slider any more. The red LED light is indicating the Volume for the Internal Part which we have switched OFF. The position of the Slider is your indication of 'how loud' your external device is...

 
Posted : 11/02/2022 5:13 pm
Dileepa
Posts: 0
Eminent Member
Topic starter
 

Hi Jason, Bad Mister.
Thanks a lot for your time explaining a lot of things here. You haven't understood my question here.
I haven't mentioned any "NOT SOUNDING" issue. Let's forget the Voicelive or any external device controlling.
My question is, when I switch on the Zone Settings for some reason, Montage (That particular patch which I have switched Zone Settings on in) doesn't recognize the midi messages sent from the Set List Maker. But when I switch Zone Settings off, it does. As I mentioned earlier I send MSB, LSB and Program Change Number from Set List Maker.
Hope this is clear enough. (You have to excuse me if what I say is kind of not clear since English is not my mother tongue).
Thank you once again. So appreciate your help!!
Stay safe!!!!

 
Posted : 12/02/2022 12:36 am
Jason
Posts: 7943
Illustrious Member
 

If this is a problem with receiving MSB/LSB/PC from an external device TO Montage - then, yes, I had the problem misunderstood.

If you notice a difference between Zone ON and OFF - I wonder if the problem is tied to an interesting "feature" of Zone control IF you have your instrument configured in single-channel (or hybrid) MIDI modes.

If, except for this Performance, you normally have your instrument setup to single-channel mode or hybrid mode then turning on Zone control will defeat this setting and place your instrument into multi (MIDI) channel mode. What MIDI channel is your Set List Manager (iPad) set to send to? If it's not channel 1 then that could be an issue.

If that's the situation, then you would need to configure the Set List Manager to transmit on channel 1.

This may not "work" for your single-channel (or hybrid) mode operation if you are "normally" using one of those two modes. You would be setting one or the other in your [UTILITY] settings. It would not work when your transmit/receive channel is set to something other than Ch1 for single-channel/hybrid mode. If this is the case, you'll have to resolve it on one end or the other (Montage or Set List Manager). I don't know the options for this iPad app.

Let me know what your MIDI mode is. Multi, Single, or Hybrid.

See left-side of picture ...

[UTILITY], Side Menu: "Settings" -> "Advanced"
Parameter: MIDI I/O Mode

Also (if exists) the MIDI I/O Ch. value.

 
Posted : 12/02/2022 7:04 am
Dileepa
Posts: 0
Eminent Member
Topic starter
 

Hi Jason.
Thank you for the reply. Problem solved 😀
Thank you for your help!!
Stay safe and healthy.....

 
Posted : 13/02/2022 3:47 pm
Share:

© 2024 Yamaha Corporation of America and Yamaha Corporation. All rights reserved.    Terms of Use | Privacy Policy | Contact Us