Synth Forum

Notifications
Clear all

Annoying MIDI feedback on Kbd Ctrl - can it be stopped?

4 Posts
3 Users
0 Likes
107 Views
Posts: 6
Active Member
Topic starter
 

I use my MODX with Cubase through a USB port in my Windows 10 PC. Playing the keyboard on each part results in a bit of MIDI feedback (it's MIDI notes being duplicated from the PC) that gives a comb filter kind of distortion which can be stopped by turning off the Kbd Ctrl for each part so that there's no duplication of notes. I use MIDI Rec on DAW quick setup preset with Local Control off. But editing the patch or selecting a new patch requires Kbd Ctrl to be turned off again each time. It doesn't occur when I play the MODX from another keyboard. How might I fix this so that the feedback stops happening?

This topic was modified 3 months ago by Rebecca
 
Posted : 29/02/2024 3:08 pm
Posts: 779
Prominent Member
 

I use my MODX with Cubase through a USB port in my Windows 10 PC. Playing the keyboard on each part results in a bit of MIDI feedback (it's MIDI notes being duplicated from the PC)

The 'missing' info is WHY are you doing that? Are you recording? Track by track? What are you trying to achieve?

That happens because for your configuration of Modx and Cubase you:

1. play the part locally on the Modx

2. send the part's MIDI data to Cubase

3. Cubase sends the part's MIDI data back to the Modx

4. Modx plays the part's MIDI data that it receives from Cubase - playing it twice with a slight delay

You have a 'feedback loop' in your configuration.

that gives a comb filter kind of distortion which can be stopped by turning off the Kbd Ctrl for each part so that there's no duplication of notes.

Yes - that prevents step #1 above from happening. Your other choice to break the 'loop' is to configure Cubase to prevent #3 from happening.

The available solutions will depend on the version of Cubase you are using.

Jason knows all about this issue so while you wait for his reply you might want to read what Bad Mister explains here:

https://yamahasynth.com/community/montage-series-synthesizers/cubase-and-montage-muffled-sound-when-recalling-instruments-back/#post-89069

 

 

 

 
Posted : 29/02/2024 5:45 pm
Posts: 6
Active Member
Topic starter
 

Thanks for that. Although the linked article by BM doesn't provide a solution, I think I've solved it. I turned off MIDI Thru in Cubase Preferences (which I don't think varies according to the version of Cubase), turned MODX Local Control back to On and left the MODX Part's Kbd Ctrl On. No feedback and the Kbd Ctrl defaulting to On causes no problem.

This post was modified 3 months ago by Rebecca
 
Posted : 01/03/2024 11:35 am
Jason
Posts: 7930
Illustrious Member
 

Local Control, which you say is turned off when using MIDI Rec On DAW is a global setting and shouldn't change unless you change it (manually, or by loading a backup or user file that sets it back).  Even if you're editing "patches".

 

Keyboard Control is a different thing.  It's not global - there's a keyboard control blue/green square for each Part on the [PERFORMANCE] (HOME) screen.  You shouldn't need to do anything with these when Local Control is OFF.  Local Control is all you need to prevent the doubling.

 

If you have something that's working for you - great.  

 
Posted : 19/03/2024 1:47 pm
Share:

© 2024 Yamaha Corporation of America and Yamaha Corporation. All rights reserved.    Terms of Use | Privacy Policy | Contact Us